0 votes
in CCTV by
I have connected my Hikvision NVR to my router directly using an Ethernet cable and set the recorder to use DHCP. Hik-connect is enabled but still says offline...

What am I doing wrong?

1 Answer

0 votes
by Bronze member (4.4k points)

There are a couple of reasons this might happen.

  • The device isn't connected to or working on your local network
    • In the recorders menu locate the network settings and verify that the recorder has an IP address. In most cases enabling DHCP will enable the router to assign an address.
    • Run Hikvision's SADP software on a computer on the same local network and verify that the recorder shows in the list
  • Your ISP is blocking access to Hik-connect
    • Changing the DNS settings in the recorder from automatic to manual sometimes resolves this. Enter public DNS addresses in the primary and secondary boxes for example Googles public DNS addresses are 8.8.8.8 and 8.8.4.4

46 questions

43 answers

2 comments

5 users

Welcome to the Connectec Q&A forum.

Please keep questions and answers concise and to the point, use comments if you need clarification or want more information from a poster and try to be as considerate and helpful as possible to other members.

Please read the forum rules for more information.
...